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Introduction
The Hot Potatoes software program is a set of five authoring tools which can be used to create interactive Web-based exercises. Created by the University of Victoria in Canada, this software is freeware. 
The five tools available are:
	JQuiz
	Creates 4 different types of exercises:

· multiple choice

· short answer
· hybrid questions 
· multi-select question 
(See Appendix for details)
	Specific feedback can be provided both for right answers and predicted wrong answers or distractors. In short-answer questions, the student's guess is intelligently parsed and helpful feedback to show what part of a guess is right and what part is wrong. The student can ask for a hint in the form of a "free letter" from the answer. 

	JMix
	Creates jumbled sentence exercises 


	You can specify as many different correct answers as you want based on words and punctuation in the base sentence. A hint button prompts the student with the next correct word or segment. 

You can also produce drag-and-drop exercises if using more recent browsers.


	JCross
	 Creates crosswords 
	The grid can be virtually any size. A hint button allows the student to request a free letter.


	JMatch
	Creates a matching or ordering exercise 


	A list of fixed items appears on the left (pictures or text), with jumbled items on the right. This can be used for matching vocabulary to pictures or translations, or for ordering sentences to form a sequence or a conversation. You can also produce drag-and-drop exercises if using more recent browsers.

	JCloze
	 Creates gap-fill exercises.
	Unlimited correct answers can be specified for each gap. Students can ask for a hint and see a letter of the correct answer. A specific clue can also be included for each gap. Automatic scoring is also available.
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Where can I get Hot Potatoes? 

Hot Potatoes can be downloaded from http://hotpot.uvic.ca/
· The current version is Version 6.3
· Available in both Windows and Macintosh formats.
· Make sure you set the program to Advanced mode – this gives you full use of the program.

http://hotpot.uvic.ca/[image: image6.png]



Useful Menu Items
Edit Menu – Spell check – check the spelling in all questions/answers/links in the exercise
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Manage Questions Menu – can be used to insert, delete, move and clone questions as well as view an outline of the questions in your quiz. You can also shuffle the order of the questions and/or answers in the quiz.
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Options Menu – the Font menu item can be used to change the font, font style, size and font colour used for exercises.
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How do I create Hot Potato resources?
The format to create all types of quizzes is: 

1. Enter your data

You type in the questions, answers, feedback etc. which forms the basis of the exercise. 

2. Adjust the configuration

The "configuration" is a set of information used to compile the Web pages. It includes instructions for the student, captions for navigation buttons, options for screen colours and other information which is not likely to change much between exercises. 
3. Save the original Hot Potatoes file

4. Create your Web pages (exporting as a web page)
This is simply a matter of pressing the "Export to Web" button on the toolbar and choosing a file name. The program will create a web document (html). 
Points to note:
· When creating a set of Hot Potatoes exercises it is important that all exercises and any associated pictures, sounds or videos making up a unit are contained in one folder. You can create another folder within the main folder to hold your graphic, sound, video files.
· You must save a quiz before you can insert images. 
· You can make changes to your quiz by opening the original Hot Potatoes file after launching the Hot Potatoes program.

· You will need to export your new quiz to a web page again after changes are made.

· When exporting the exercise as a web page you will need to name the page. Follow the following guidelines when saving a webpage or graphic for the web:
· Do not use any spaces in the file name

· Use only lower case letters

· You can use the same name for the web page as you have for the quiz

· If you are using two or more words you can separate them with an underscore, e.g. parts_of_body

· Do not use punctuation marks in the file name e.g. comma, apostrophes.

· You can use a hyphen to separate words e.g. parts-of-body

· Try to make the filename short
· Your exercise can be posted on the internet; intranet or you can use the exercise off-line.

· Hot Potatoes quizzes can be linked together so students can go from one exercise to another or a “table of contents” page can be created using web page software such as FrontPage.

· If using graphics in your quiz it is best to resize the graphic to a smaller size (about 100 x 100 or a little bigger) before inserting into your quiz. 

· PIXResizer is a freeware program that very easily and quickly resizes an image. You can convert a single image or an entire folder of images at the same time. It can be downloaded from http://bluefive.pair.com/pixresizer.htm
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The Hot Potatoes Screen

Common toolbar icons
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Getting started

· Create a new folder to hold the exercises. Navigate to your home directory, from the File menu select New then select Folder. Name the folder with Potatoes and your name.
· Create another folder within this folder to hold the graphics. Name this folder images.

Using JQuiz to create a multiple-choice quiz
· From the main screen select JQuiz[image: image38.png]oze ed m]
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· Select Multiple Choice from the drop down menu on the end right hand side of the Question box.

· Type in a Title for the exercise in the Title space

· Save your JQuiz in a new folder.

· Type in the first question (Q1) in the space provided

· [image: image39.png]Gapped word alternatives
“ b Be X

Gap# 1 7

Word elephant

Clue

Alternative correct answers




Under Answers type in the possible answers in the spaces A, B, C, D

· If more alternatives are required click on the up arrow next to Answers
· Under Settings, click in the box next to the correct answer

· [image: image40.png]& JCloze: U:\Hot Potatoes\PracticeExercises\ZooAnim. ..
Fil Edit Insert Options Help

aeHB RV

BHEHH BE | 2
Title

Animals at the Zoo

[The largest animal in the zoo is the eiephant. |t has a long tunk and moves very slowly. It uses its
truric to hold food and spouts water from it

\Another large animal is the goriliz|

‘ & Delete Gap ‘

f Auto-Gap

Clear Gaps & ShowWords

Config: englishé.cfy



[image: image41.png]Insert

& Configuration file: C:\Program Files\HotPotatoes6\engli...
Edit

{Tiflesfnsiructions | Prampts/Feedback | Buttons | Appearance | Timer | Other | Custom| ca1 |

Exercise subtite
Gap-fil exercise

instructions:

Fill i all the gaps, then press "Check” to check your answers. Use th

" button 1o get a
free letter if an answer is giving you trouble. You can also click on the “[?]" button to et &
clue. Note that you will lose points if you ask for hints or clues!




Under Feedback, type in a comment that will be displayed if the student selects that answer (optional)
· Click on the up arrow next to to add Q2.

· Type in your next question/s and set of answers

· Save your completed exercise
Configuration
· This determines how the exercise will appear to the students once it has been exported to the web.

· The configuration file is shared by the entire Hot Potatoes suite. You may not need to change all settings for each quiz.
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From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· The Configuration file is displayed. There are 8 tabs. We will not be making changes to all settings.
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Tile/Instructions tab:

[image: image44.png]Animals at the Zoo

Gap-fill exercise

Fillin all the gaps, then press "Check to check your answers. Use the "Hint" button to get a free letter if an answer is giving you
trouble. You can also click on the "[7]" button to get a clue. Note that you will lose points if you ask for hirts or clues!

The largest animal in the zoo is the [? | tthas along [?] | and moves very slowly. It uses it's
[?] |to hold food and spouts [ | fromit.
Another large animal is the ]

Check Hint.




[image: image45.png]File Edit Insert Options Help

peHROR®Y |- - on B 2|

Title ||

Main sentence

Alternate sentences

lep

Options for altemate sentences

@ Allow sentences which do not use allwords and punctuation in main sentence.

© Warn if altemate sentence does not use all words and punctuation in main sentence

(Config: englishé.cfy





[image: image46.png]File Edit Insert Options Help

PCHBOR®Y =i ue B[ 7
Title Animals at the Zoo

Main sentence Alternate sentences

Elephants -
are -
big —
and

have 1
a
large
trunk

~Options for altemate sentences
 Allow sentences which do not use all words and punctuation in main sentence,

© Warn if altemate sentence does not use all words and punctuation in main sentence

(Config: englishé.cfy





[image: image47.png]E/Configuration file: C:\Program Files\HotPotatoes6\ensl|
Edit Insert
Tiesiinstustions | PromptsFeedback [BER | appearance | Tmer | otrer| custom| oo |

Caption for"Check Answer' bution: Check

3

Caption for "0K" button:
¥ Include "Undo* button caption: [Undo

¥ Include "Restart’ button Caption: [Restart

¥ Include "Hint" button Caption: [Hint

Navigation
™ Include "Next Exerciss” button Caption:

W Include "Go to Contents” button Caption: |Year 5 Exercises

Contents page URL: findex.htm

I™ Include "Back’ bution Caption:

Heae Bl save s





[image: image48.png]



Prompts/Feedback tab:
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Buttons tab:
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“Next Exercise” URL: this gives the name of the page containing the next exercise if there is more than one exercise in your unit. It must be an .htm file (web page).
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Contents page URL: It is useful to have an index page that lists all the quizzes with a link to them. The default name is index.htm but it can be re-named if needed. An index page can be created using Frontpage.

Note: The above three options control the navigation between a set of quizzes. If you are not linking quizzes together, or do not have a main index page for the quizzes, clear these check boxes. If you do not, the message “Page cannot be displayed” will appear in
[image: image58.png][ Microsoft FrontPage - U:\HotPotatoesSitelindex.htm
File Edit View Insert Format Tools Table Data Frames Window Help Type a question for help Max|
oS b3 Fm g8 FIsaB S0 - eaEe 830, »LN:)/!

Normal = Times New Rorman ~3 (2p) »|B Z U A |@-¥-A-

5 webste || indeschtm
Bz

it B Qe |

0:01@S6Kbps 835 % 54 Custom Custom




Appearance tab:
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Other tab:
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Notes: 

· The Timer tab is used to set a time limit for answering questions.

· Custom and CGI tabs do not need to be changed. 

· Only change those options that make sense to you!

· The settings for the features that are constant across the different quiz types will not have to be set each time you construct a new quiz.

Saving

· Click OK when the configuration file has been completed

· Click Save to save your quiz. Save the quiz in a new folder in the same folder that contains your images.

· The quiz will be saved as a Hot Potatoes file.

Saving the quiz as a web page
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Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· The file will be saved as an htm file.
· If you have previously saved the file as a web page the following message is displayed:
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· Select Yes. This will overwrite the previous file so you will always have the most current file saved.
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· Each time the file is saved as a web page, the following message is displayed:

· Select View the exercise in my browser. This will show what the exercise looks like when the students access it from the internet/intranet/web page format.
Sample Multiple Choice quiz as it appears as a web page.
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Note:
Hot Potatoes will save two files for each quiz created in the folder created.

· A Hot Potatoes program file (can be edited using the Hot Potatoes program)

· A web page (htm) file (can be changed only by re-exporting the edited Hot Potatoes file)
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Using images in a multiple-choice quiz
You can insert a picture into the question area to use as a question if required.
· Make sure you have the images saved in the same folder as the quizzes.  Hot Potatoes expects to find the images in the same folder as the quiz. If not, the program will warn you that a relative path could not be created.
· You must save your quiz before you can insert an image. The following message is displayed if you have not saved your quiz.
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Click in the question space

· From the Insert menu select Picture then Picture from Local File
OR
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Click on the Insert a picture from a file on your hard drive icon from the toolbar. 

· Locate and click on the image you want to use.

· Only graphics with the format .gif, .jpg or .png can be used in this program.

· Click Open
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The dialog box displayed can be used to change the width and height of the image and to set the picture’s alignment. It is best not to have the images too large. (About 100 x 100)
· Delete the text next to Alt Text: and Title: to make sure the name of the image is not visible when the quiz is displayed as a web page.

· The image is not displayed, the location (path) of the image is displayed in the question area.

· Type in your questions and answers.

· Make sure to check the box next to the correct answer.

· Enter as many pictures and sets of possible answers as you wish.
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· Configure and save the file.

· Export the file to a web page.

Sample Multiple Choice Quiz using graphic images as it appears as a web page.
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Sample short-answer exercise using JQuiz
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 Adding a reading text to quizzes    
All of the Hot Potatoes programs give you the option of including a reading text in a separate frame next to your quiz. (The only exceptions to this are the drag-and-drop output from JMix and JMatch -- drag-and-drop exercise using only half of the page is not practical.) 
The reading text may be typed directly into the program, or it can be an imported from an external Web page.  
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· Click on Add Reading Text from the File menu or click on the button on the toolbar to bring up this screen. 
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.

· Click the box next to Include a reading text to include a reading text pane in your web quiz.

· Give a Title to the text passage

· Type in some text into the provided area 

OR

· Import some text from a html file (not recommended – too much tidying up is required)

· The reading text pane will be visible when the quiz is viewed as a web page.

Using JQuiz to create a short-answer quiz 
· In this type of quiz, the student has to type the answer into a text box on the page, and press a Check button to see if it is correct.

Note:
The JQuiz interface will change only slightly when creating a hybrid or multi-select quiz. Once the configuration has been set and the quiz is viewed in a web browser the format will reflect the quiz type.

· From the Start menu open Hot Potatoes

· From the main screen select JQuiz

· Select Short-answer from the drop down menu on the end right hand side of the Question box.

· Type in a Title for the exercise in the Title space

· Under Question type in the question

· Under Answers type in the answer
· Under Settings, click in the box next to Correct for the correct answer
· Under Feedback, type in a comment that will be displayed if the student selects that answer (optional)

· Save your completed exercise

Configuration
· [image: image82.png]Took



From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· Make any changes you require and then save your quiz.

Saving the quiz as a web page

· [image: image83.png]


Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.
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Select View the exercise in my browser. This will show what the exercise looks like when the students access it from the internet/intranet/web page format.
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Using JQuiz to create a hybrid quiz
· A hybrid quiz is a combination of a multiple-choice question and a short-answer question. In this type of question, the student is first presented with a text box and asked to type the answer. If the student fails to get the answer right after a specified number of tries (which you can set in the configuration screen), the question changes to a multiple-choice question to make it easier. 
· When creating a hybrid question, you'll see an extra checkbox on the right: Include in MC answers (include in Multiple Choice answers). Check this checkbox for any answer you want to appear as part of the multiple-choice answers in the second phase of the question.

· From the File menu select New to start a new quiz using JQuiz
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OR

· From the toolbar click on the Start new blank quiz icon (or press Ctrl N) 

· Select Hybrid from the drop down menu on the end right hand side of the Question box.

· Type in a Title for the exercise in the Title space
· Under Question type in the questions
· Under Answers type in the answers
· Under Settings:

· click in the box next to Correct for the correct answer
· click in the box next to include in M/C options to have this answer included in the multiple choice selection

· Under Feedback enter some feedback if needed.

· Save your quiz
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Configuration
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From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· Make changes to the configuration file as needed (e.g. Appearance, Titles/Instructions)

· Click on the Other tab

· Set the number of attempts you want the students to have to answer the short answer question before it becomes a multiple-choice question.
[image: image89.png]& Configuration file: C:\Program Files\HotPotatoes6\engl.
Edit Insert

Tlessnstuctions | PromptsiFestback | Buttons | ppearance | Timer Other | custom | coi |

I~ Show a limited number of questions each time the page loads
¥ Shuffle order of questions each time page loads
¥ Shuffle order of answers in each question when page loads
[ Show number of questions answered correctly in one guess
¥ Show score after each comect answer
I~ Make answer-checking case-sensitive
I~ Show list of ther correct answers
2] attempts are allowed before a hybrid question switches to muttiple-choice.
I~ Do special processing to hande right-to-left language data in the output.

[~ Create a separate linked file containing the JavaSeript code

I~ Include a keypad to help the student type non-roman characters
Always include these characters on the keypad:




[image: image90.png]Q ed
File Edit Insert Manage Questions Options Help

2eRRCEY |~ im0 | GEGS | B[ 2 |

Title Grammar

Q|1 il Which of the following words are nouns? [Mutti-select
a "
v Answers Feedback Settings

mother v Bhouid be seiecied
A

Tather ¥ Should be selected
B

baby % Should be selected
c

un I~ Should be selected
D

Confin: englishé.cfa





Saving the quiz as a web page
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Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· Select View the exercise in my browser. This will show what the exercise looks like when the students access it from the internet/intranet/web page format.
· The quiz will appear as a short- answer quiz when the page is loaded. It will change to a multiple-choice quiz after the student has answered the question incorrectly after the allowable attempts.

· Test you quiz
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Sample Hybrid Quiz
Using Hot Potatoes to create a multi-select quiz
Students select several items from a group of items. The idea here is that the student must select all the correct items in the list, and not select the wrong items. E.g “Which of the following words are nouns?”
· From the File menu select New to start a new quiz using JQuiz
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OR

· From the toolbar click on the Start new blank quiz icon (or press Ctrl N) 

· Select Multi-select from the drop down menu on the end right hand side of the Question box.
· Type in a Title for the exercise in the Title space

· Under Question type in the question
· Under Answers type in the answers, one word in each answer box:

· Under Settings:

· click in the box next to Should be selected for the items that are correct answers
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Configuration
· [image: image95.png]


From the toolbar click on the Configuration icon 

OR

From the Options menu select Configure Output
· Make changes to the configuration file as needed (e.g. Appearance, Titles/Instructions)

· Under the Titles/Instructions tab:

· Under Instructions type in a suitable instructions for this type of quiz such as “Select all the correct answers in this list” 
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Saving the quiz as a web page
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Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Select View the exercise in my browser. This will show what the exercise looks like when the students access it from the internet/intranet/web page format.
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Creating a drag and drop match up exercise using JMatch
JMatch lets us create matching exercises. You can use images or words as your list. The exercise can be exported to the web in one of two formats:

· As a drag-and-drop exercise

· As an exercise which uses a drop-down menu for the available choices
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From the main Hot Potatoes screen click JMatch

· Insert a Title for the exercise in the title area.
· [image: image100.png]


Save the file, click on the Save this exercise to disk icon in the toolbar. 

(Disk with red trim)

· Insert the ordered list on the left hand side, one item in each box. This can be an image or word.
· To insert an image:

· Make sure the images are saved in the same folder your exercise will be saved in.

· Click in the first space.
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Click on the Insert Picture from a file on your hard drive icon in the toolbar. 
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OR 

From the Insert menu select Picture…Picture from Local File
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Locate your image
· Edit the width of the image to about 100. The height will automatically be adjusted if Maintain aspect ratio is ticked.
· You can set the alignment of the picture to Left, Centre, Right or None.

· Click OK
· The image is not displayed, only the location (path) of the image is inserted.

· Only graphics with the format .gif, .jpg or .png can be used in this program.
· Delete the text next to Alt Text: and Title: to make sure the name of the image is not visible when the quiz is displayed as a web page.

· Save your file. 
· Make sure it is saved in the same folder as the images.
· Write the corresponding name of the image/item in the right hand column. This must match the item in the left hand column. The program will jumble the order of answers.
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Save the file
Configuration
· This determines how the exercise will appear to the students once they have been exported to the web.

· The configuration file is shared by the entire Hot Potatoes suite. You may not need to change all settings for each quiz.

· There will be slight differences to some of the configuration options for different types of quizzes. Always check the configuration before exporting to a web page.
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From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· The Prompts/Feedback tab for JMatch quizzes has fewer options than JQuiz.
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Saving

· Click OK when the configuration file has been completed

· Click Save to save your quiz. Save the quiz in a folder containing all other quizzes. Don’t forget to make sure your images are also saved in this folder.
· The quiz will be saved as a Hot Potatoes file.

Saving the quiz as a web page allowing drag and drop
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· Click on the button with the spider’s web and mouse pointer (Export this exercise to create a drag and drop web page for version 6 browsers)

OR

From the File menu select Create Web Page…Drag/Drop web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· The file will be saved as an htm file.

· Each time the file is saved as a web page, the following message is displayed:
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· Select View the exercise in my browser. This will show what the exercise looks like when the students access it from the internet/intranet/web page format.
Note:
Hot Potatoes will save two files for each quiz created in the folder created.

· A Hot Potatoes program file

· A web page (htm) file
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Sample Matching Exercise using drag and drop as it appears as a web page.

Note: If the images are too large you can open the original Hot Potatoes file, delete the image, re-size it and then re-insert the image.
The JMatch exercise can also be saved as an exercise that uses a drop down list of items to choose from to match the correct word to the image. We simply save the file as a normal web page.
Saving the quiz as a web page
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Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
Sample JMatch Matching Exercise saved as an ordinary web page as it appears as a web page.
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Note: This format is useful when there are too many images to fit on one drag-and-drop web page.
Creating a cross-word using JCross
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From the main screen click on JCross
· Add a title to your exercise in the space under Title
· Call your cross-word What am I?

· Save your exercise in the folder you created.
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Click on the grid icon in the toolbar (Create grid layout automatically from a list of words)

OR

From the Manage Grid menus select Automatic Grid-Maker
· The following dialog box is displayed.

· Enter the answers in the space provided, one word per line.
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The maximum grid size can be controlled. Keep it to a minimum so the entire grid can be seen in the browser window.
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Click on Make the grid. The program will attempt to fit as many words into the grid as possible.

· The cross-word shape will be displayed.
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Use the arrows to move the cross-word to the desired location on the grid.
· Click on Add Clues to add the clues
· Click on a word. Type in the clue in the space provided.
· Click the OK next to the clue
· Click OK when all clues have been added.
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Configuration
· This determines how the exercise will appear to the students once they have been exported to the web.

· The configuration file is shared by the entire Hot Potatoes suite. You may not need to change all settings for each quiz.
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From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· The Configuration file is displayed. There are 8 tabs. You will not need to make changes to all settings.

· Use the Appearance tab, to change the appearance by changing the background colour, text colour etc.

· Under the Other tab, click on Show all clues below the cross-word grid if you want the clues to be visible as soon as the cross-word is displayed.
· You may set a time limit (Timer tab) if required.
Saving
· Click OK when the configuration file has been completed

· Click Save to save your quiz. Save the quiz in a folder containing all other quizzes. Don’t forget to make sure your images are also saved in this folder.

· The quiz will be saved as a Hot Potatoes file.
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Saving the quiz as a web page
· Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· The file will be saved as an htm file. Select “View the exercise in my browser” to see the exercise as it will appear on the web.

Note: 

· Click on each number in the cross-word to bring up the question. 

· Type in the answer then press Enter to enter the answer into the cross-word.
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Creating a gap fill (cloze) exercise using JCloze
· From the main screen select JCloze
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« We no longer provide any technical support for Hot Potatoes or Quandary.

What is Hot Potatoes?

The Hot Potatoes suite includes six applications. enabling you to create interactive multiple-choice, short-answer, jumbled-
sentence, crossword, matching/ordering and gap-fill exercises for the Waorld Wide Web. Hot Potatoes is freeware. and you may
use it for any purpose o project you like. It is not open-source

»





· Type the title of the exercise in the Title box.

· Save the file.
· Type in the whole text in the main area.

· Select to words you want the students to fill in by clicking and dragging the mouse across the word to highlight it.

· Click on Gap. 

· The dialog box displayed allows you to enter a clue for the students. It also allows you to enter any alternative words that could be used.

· Click Ok when finished.

· Use Delete Gap to delete the gap placed on a particular word.
· Use Clear Gaps to clear all the gaps set.
· Auto-gap will assign gaps to the text automatically.
· The text will be displayed with the word that will be replaced by a gap underlined in red.

Configuration
· This determines how the exercise will appear to the students once it has been exported to the web.

· The configuration file is shared by the entire Hot Potatoes suite. You may not need to change all settings for each quiz.

· From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· The Configuration file is displayed. There are 8 tabs. We will not be making changes to all settings.

· The Appearance tab can be used to make changes to the appearance by changing the background colour, text colour etc.
· You may wish to change the instructions for the students in Titles/Instructions tab.

· You wish to make changes to the text in the Prompts/Feedback tab.

· Remember, if you don not make any changes to the configuration file, it will use the settings already stored.



· The Other tab contains some additional options to include with this type of exercise.

· Options you may like to include:
· Include word list with text. This inserts the list of the words the students can choose from.

· Make answer-checking case sensitive.  For case sensitive checking.

· Use drop down list instead of text box in output. This lets the students choose the correct word from a drop down list.


Saving

· Click OK when the configuration file has been completed

· Click Save to save your quiz. Save the quiz in a folder containing all other quizzes. Don’t forget to make sure your images are also saved in this folder.

· The quiz will be saved as a Hot Potatoes file.

Saving the quiz as a web page
· Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· The file will be saved as an htm file. Select “View the exercise in my browser” to see the exercise as it will appear on the web.

Note:
You can also add images to this quiz. Place the cursor at the location you want to insert the image and then insert an image from file.

Sample JCloze exercise as it appears as a web page.


Creating a re-ordering exercise using JMix

This allows us to create a jumbled sentence where the student has to put the parts of the sentence back into the correct order.

· From the main screen select JMix
· Type in a title for the exercise in the Title box.

· Save your file

· In the Main Sentence box type in the sentence in the correct order, with each part of the sentence on a new line.
· In the Alternate Sentences box you can type in any other possible sentence order. There is no need to fill in this section.

· Save the file
Configuration
· This determines how the exercise will appear to the students once it has been exported to the web.

· The configuration file is shared by the entire Hot Potatoes suite. You may not need to change all settings for each quiz.

· From the toolbar click on the Configuration icon 

OR

From the Options menus select Configure Output
· The Configuration file is displayed. There are 8 tabs. We will not be making changes to all settings.

· The Appearance tab can be used to make changes to the appearance by changing the background colour, text colour etc.

· Changes to an option in the Buttons tab is needed for this type of exercise. 

· Check the box next to Restart. This allows the student to restart the exercise if a mistake is made.

· You may also include a Hint button to provide a hint to the student.

· The Undo button will undo the sentence created.

· Remember, if you don not make any changes to the configuration file, it will use the settings already stored.


Saving

· Click OK when the configuration file has been completed

· Click Save to save your quiz. Save the quiz in a folder containing all other quizzes. Don’t forget to make sure your images are also saved in this folder.

· The quiz will be saved as a Hot Potatoes file.

Saving the quiz as a web page
· There are two options available for this type of quiz.

· Export to create a Hot Potatoes version 6 web page. Students click on each word to place it in the answer space in the correct order.

· Export this exercise to create a drag and drop web page for version 6 browsers. This allows students to drag and drop each word into the answer space in the correct order. 
· Click on the button with the spider’s web (Export to create a Hot Potatoes version 6 web page)

OR

· From the File menu select Create Web Page…Web page for v6 browsers
· Save the quiz using the same name as the original Hot Potatoes quiz. This makes it easier if you need to edit the quiz at a later stage.

· The file will be saved as an htm file. Select “View the exercise in my browser” to see the exercise as it will appear on the web.
Sample JMix exercise as it appears as a web page as a “click the word” exercise. 
The exercise includes a Restart button, an Undo button and a Hint button since these were checked in the configuration file.
Sample JMix exercise as a drag and drop exercise.

How do I modify quizzes I have already created?
· Open the Hot Potatoes program.

· Select the type of quiz used.

· Open the original exercise file.

· Make the changes; make changes to the configuration file if required.

· Save the file with the same name.

· Export the file to a web page. (Answer yes to overwrite the existing web page)

Using sound files in Hot Potatoes quizzes

You can include sound in your “Hot Potatoes” quizzes by using the Insert….Link…Link to Local File option.
· Develop a quiz of your choice.

· Make sure you have saved your exercise in the Hot Potatoes quizzes folder first. 
· Make sure you have saved the sound files in the same folder as the quizzes.
· Click on Insert…Link…Link to Local File. 



· If the following warning is displayed, you need to save the Hot Potato quiz in the same folder as the web page file (html) file will be saved in so the link to the sound file can be found.


· Once you have saved your quiz in the required location the following dialog box is displayed. This provides with you with the details of the location of your saved file and tells you that the html file created will also be saved in this location.


· Click OK to bring up the Open dialog box. 
· Locate the sound to insert. Make sure the sound is in the same folder as the quiz (or within a folder in the quiz folder)

· Click on the sound file then click Open. 
· You will now see the Insert Link dialog box.


· In the Link Text box, type an appropriate piece of text, such as "Click here to listen to the sound". 

· Click OK. 
· Save your file 

· Export the file to a web page

Note: 

When the quiz is viewed as a Web page, there is a link to the sound in the question. Clicking on the link will play the sound file. 
Note that how the file is played (what application is used to play it) depends on the user's browser. Sometimes QuickTime will pop up, sometimes the Windows Media Player, and sometimes another application; it all depends on what is installed on the user's machine, and you have no control over that. 
However, something should always appear which can play the file, as long as the user's computer is able to handle sound.

Note: Your link to the sound file may be an image. Make sure you have your images saved in the same folder as your Hot Potatoes quizzes before you link to it.

To have an image link to a sound file:

· Type in your question (for example, What am !?) and answers and repeat the steps above to insert the sound file until the Insert Link dialog box is displayed.


· Under Link delete the text next to Link text: as we are using an image as a link instead of text.

· Under Link, click on Picture
· The Open dialog box is displayed.

· Navigate to the folder containing the image, click on the image once, click on Open.


· The image dialog box is displayed. Changes can be made to the size of the image and the picture alignment.

· Deleting the text next to Alt text: and Title ensures that the name of the image is not seen if the mouse is placed over the image on the web page.

· Click OK when all changes have been made.


· Save your quiz

· Export your quiz to a web page.

· Preview your quiz as a web page.

Sample multiple-choice quiz incorporating a sound file.



New Features of Hot Potatoes

Version 6.2.0.9 of Hot Potatoes introduces only one new feature: case sensitivity in JCross. You can now create crosswords which use lower-case letters, and have answers accepted or rejected based on case. 

Version 6.2 of Hot Potatoes introduces support for SCORM 1.2. You can now output your exercises in the form of SCORM packages which can be imported into learning management systems that support SCORM e.g. Moodle

· Using the Create SCORM package function on the File menu, you can now create a SCORM 1.2 zip package containing your exercise HTML file, along with any associated media files it requires. A SCORM package can be uploaded into a Learning Management System such as Moodle, enabling the exercise(s) to report their scores and other information to the LMS. 

Version 6.1 of Hot Potatoes introduces one new feature, Create zip package, which enables you to create a portable zip archive of your exercise, along with any related media files.
· Using the Create zip package function on the File menu, you can now create a portable zip package containing your exercise HTML file, along with any associated media files it requires. 
Printing “Hot Potatoes” exercises
Exercises created using “Hot Potatoes” can be printed by using the Export for Printing option in the File menu. How the exercises are printed depends on the type of quiz being printed.

Note that only the title and questions will be printed. None of the instructions etc will be displayed.

JQuiz:

· The exercises will be copied to the clipboard and then you can paste the into a word processor document to print.


· Images are not printed. The source (location address) is printed.

· The text in the reading pane (if used) will be printed first, then the questions.

JCloze
· The exercises will be copied to the clipboard and then you can paste the exercise into a word processor document to print. 


· The correct answer is also displayed.

JMatch
· The exercises will be copied to the clipboard and then you can paste the exercise into a word processor document to print. 


· Images are not displayed when the exercise is pasted into the word processor document. Only the link to the image is displayed.

JMix
· The exercises will be copied to the clipboard and then you can paste the exercise into a word processor document to print. 


JCross
· The cross-word puzzle is exported to the web browser and can be printed using the Print command from the File menu (or printer icon on the toolbar)


· You must set the Printing settings in the web browser to Print background colors and images for the cross-word to print properly.

· From the Tools menus select Internet Options…
· Click on the Advanced tab.  Under Printing click in the box to enable background colours and images to be printed.



Creating an Index page using Microsoft FrontPage
It is useful to create an index page with links to all the Hot Potatoes exercises created. The index page can be updated as new exercises are developed. An index page makes it easier to navigate through the different exercises. It is best to use Microsoft FrontPage to create an index page. This will enable the page to be more stable when viewed on the web.
The configuration file in each Hot Potatoes exercise will need to include the name of the index page the exercise links to.

Sample index page created using Microsoft FrontPage.

Getting started
· Open FrontPage 2003

· Click Start…Microsoft Office…Microsoft Office FrontPage 2003
OR

· Click on the short cut icon on the task bar. 

· Create a new One page Web site 

· File…New. Select One page website from the task pane. 


· Under Options choose a location to save your website. 
· Click Browse for a list of possible locations
· Choose a drive letter e.g. C:\
· Enter the name of the website after the drive letter e.g. F:\HotPotatoesSite

· Click OK
· A new folder is created labelled with the name you provided. It contains two sub-folders, ‘images’ and ‘_private’.
· From the View menu select Folder list to divide the screen into two parts. The left hand pane shows the location of the site and all the folders

· Click on the index.htm tab. This takes you to a blank page.
· Click on the close box in the folder list to hide it.
Important Screen Features

The 4 tabs at the bottom left hand corner of the window are used to navigate between different views of the web page being created.

· Design – Allows you to create and edit your page. This is a WYSWYG (what you see is what you get) interface.
· Split – Displays both Code and Design views - the window is split into two sections, one showing the html code and the other half the design view 
· Code – displays the html code only. Allows you to add, modify, and delete the HTML code for specific or advanced web page design
· Preview –Allows you to follow hyperlinks and test usability by displaying the page as it would appear in a web browser.
To preview the page as it will appear on the internet using a web browser (such as Internet explore), from the File menu, select Preview in Browser then select a web browser to use e.g. Internet explorer 6

Adding and formatting content to index.htm
We will format the page using a table layout to make it easier.

· Make sure you are in Design view.

· From the Table menu select Layout Table and Cells. 

· The Layout Table and Cells Task Pane is displayed.
From the Table Layout options, choose a suitable format.
· The page will be divided into the chosen table format. The guidelines will not be displayed in a browser. They are simply guide lines.

· Click in one of the cells.

· Click on Cell Formatting in the task pane.

· Changes to the individual cells can be made using the options provided.

· Under Layout cell properties change the BgColor (background colour) to a colour of your choice.

· Repeat for the other 3 cells.

· Note: You can also right-click on a cell and choose Cell Properties to change background colour, add a picture as a background etc.
· Click into the last cell of the table

· From the Format menu select Theme (or use the Task Pane to select Theme)

· Choose a Theme of your choice.



· Type in the title of the page in the top cell.
· Highlight the text and from the Style drop-down menu select a Heading size. (Using Styles from the drop down menu list is recommended as “themes” can be used if styles are applied.)
· Highlight the title and justify centre, select an appropriate text colour

· Save and preview the page.

· Highlight the title and centre it in the cell

· From the task pane select Cell Formatting
· Under Layout cell properties set VAlign (vertical alignment) to Middle
· Insert an image in the top right hand cell of the table. This can be the school logo or any other image. Make sure you save the image in the images folder of your website.
· Click in the required cell
· From the Insert menus select Insert Picture…then 
· Clip Art… if using the available clip art
· From file… if using your own image
· If the Save embedded files dialog box is displayed check the details and click OK (this saves the images with the web page)

· Add a background sound to your page:
· Right-click on the page and select Page Properties from the short-cut menu


· In the General tab, under Background sound: Location - locate the sound file to be inserted

· Sound files must be in the format: WAV, Midi, RealAudio, AIFF, AU
· It is best to save a copy of the sound in the images folder within the website.

· Do not loop the sound as this can be very annoying to the user.


Creating links

· Click in the main body of the table

· Type in a short introduction/instructions/message

· Type in the name of each exercise created, one per line

· Highlight the name of the exercise

· From the Insert menu select Hyperlink
OR 

· Right-click the mouse and from the short-cut menu select Hyperlink
· Make sure the Existing File or Web Page option is selected (first option on the left hand side of the dialog box)
· Find the Hot Potatoes quiz in html format that will link to the given name. 

· Look in: find the location of the file (use down arrow for a list of locations)
Very important!!
You must link to the Hot Potatoes web version of the exercise. It is recognised by the name of the file with the internet explorer icon 

Notes:

· It is best to create an index page in Front Page first and save it so you have the name of the page you want the Hot Potatoes exercises to link to. The index page does not need to be complete, just as long as it exists.

· Always check the configuration file for each Hot Potatoes exercise to make sure all the navigation options have been set correctly and the exercise links to the index page you have created in Front Page.
· It is best to save all Hot Potatoes exercise and any images, sounds, videos etc in the one folder.

· It is best to save all images, sounds etc for the web page in the one folder (usually created for your website)

· Have the Hot Potatoes exercises in the same folder as your website before linking to them from the index page. This makes it easier for the web page to find the documents and will avoid broken links that occur if the exercises are moved once they have been linked.

Setting the Configuration File
Each Hot Potatoes quiz created must have the configuration file set to the name of the index page created in FrontPage.

· Open the Hot Potato quiz from the Hot Potatoes Program

· Click on the configuration file icon on the toolbar to configure the output.

· From the configuration file, click on the Buttons tab


· Under Navigation:

· Click in the box next to Include “Go to contents” button to select it.

· Next to Caption: write what you want displayed in the title bar of the web page quiz e.g. Hot Potato Quizzes

· Next to Contents page URL: type in the name of the index page created in FrontPage e.g. index.htm

OR

· Click on Browse…to locate the index page and click on its name.

· This will link the quiz to the index page created in FrontPage.

Note:

The Navigation (under the Buttons tab) must be set for each Hot Potato quiz you want to include in the index.
Viewing Hot Potatoes exercises through a web browser
Open the folder containing the Hot Potatoes files. You do not need to have the Hot Potatoes program open – it is best not to have it open.

The folder will contain all files created by the progam, including:

1. The Hot Potatoes files

2. The web pages

Example: 


All the files with the Internet Explorer symbol are the web pages.

Double click on the namer of the file to open and view it as a web page.

Appendix 1:  JQuiz question types
JQuiz can create four different types of question: multiple-choice, short-answer, hybrid (a short-answer question that turns into a multiple-choice question after several attempts), and multi-select (in which the student has to choose several of a set of options, then check the choices). This is a detailed explanation of each question type:

 

In multiple-choice questions, the student chooses an answer by clicking on a button. If the answer is correct, the button caption will change to a smiley face :-), and if it's wrong, it will change to an X (you can configure these bits of text in the configuration screen). In either case, the student will see feedback specific to that answer, explaining why it's right or wrong (assuming you write the feedback when you make the exercise!). If the answer is wrong, the student can continue choosing answers until a correct answer is selected. The score for each question is based on the number of tries taken to get a correct answer. Once a correct answer is chosen, the scoring is "frozen", but the student can still click on buttons to see the feedback for other answers without penalty.

 

In short-answer questions, the students has to type the answer into a text box on the page, and press a Check button to see if it is correct. The page will try to match the student's answer to a list of correct or incorrect answers you have defined. If a match is found, the feedback for that answer will be shown. If not, then the page will try to find the nearest match among the specified correct answers, and signal to the student which parts of their answer are right and which parts are wrong. The score for each question is based on the number of attempts the student makes before getting a correct answer. You can also include a Hint button, which will give the student one letter of the answer; using the Hint button incurs a penalty on the score.

 

A hybrid question is a combination of a multiple-choice question and a short-answer question. In this type of question, the student is first presented with a text box and asked to type the answer. However, if the student fails to get the answer right after a specified number of tries (which you can configure in the configuration screen), the question changes to a multiple-choice question to make it easier. When you are creating a hybrid question, you'll see an extra checkbox on the right: Include in MC answers. Check this checkbox for any answer you want to appear as part of the multiple-choice answers in the second phase of the question. For example, your short-answer question may include four predicted correct answers which would be acceptable, but you probably only want to include one of them as a multiple-choice option.

 

Finally, a multi-select question asks the student to select several of a specific set of items. The idea here is that the student must select all the correct items, and not select all the wrong items. This type of question might take the format "Which of the following are nouns?", followed by a list of words. The student must check all the nouns, but not check any answers which are not nouns, then press a Check button. If the answer is not completely correct, the student will see a readout of the number of correct choices, and one piece of feedback; this would be the feedback from the first item in the list which was either selected when it shouldn't be selected, or not selected when it should be selected. 

Appendix 2: JQuiz configuration details
The configuration for JQuiz includes a lot of prompts, because each type of question requires different onscreen controls, responses and explanations. 
On the Other page of the Configuration dialog there are options for shuffling the order of questions when the page loads, and shuffling the order of answers within each question. 
You can also choose to have only a limited number of questions (selected randomly) load each time the page loads. If you combine these options (shuffling of questions and answers, and random selection of questions) you can create a quiz that will be different each time a student accesses it, making it more useful for repeated practice.
 
Also, note that you can choose whether to make answer-checking case sensitive or not. In normal circumstances, if you are making short-answer quizzes, it would probably make sense to have case-sensitivity switched off, so that it doesn't matter whether the student enters an answer in upper case or lower case. However, if your quiz asks for answers in sentences (as for example in the case of a grammar exercise), then using the correct case where necessary might be part of the exercise. In this case, case-sensitivity should be turned on.
 
Finally, both JQuiz and JCloze include the option to add an onscreen keyboard for students to type non-roman characters into answer boxes.
Appendix 3: JCloze configuration details
There are four unusual settings in the configuration of JCloze. Three are on the Other page of the Configuration dialog box. The first is Use dropdown list instead of textbox in output. If you choose this option, the following things will happen:

1. Instead of text boxes, each gap will show as a drop-down list, consisting of a list of all the gapped words in the exercise.  

2. The hint button will not be shown (because there's no need for hints if the words are all shown in the list). 

3. The keypad will not be shown (because there's no need to type answers). 

The other settings on the Other page are these:

· Make answer-checking case sensitive allows you to switch on or off case-sensitivity on the Web page (as you can do in JQuiz). 
· Include word list with text allows you to include a list of the gapped words from the text, mixed up, in a box at the top of the page, to make the exercise a little easier.

The fourth setting is Include clue button for each gap, which is on the Buttons page. If you have specified clues for your gaps, check this option to make sure that a button will appear next to each gap which has a clue associated with it, so the student can see the clue. See Adding alternate correct answers and clues for more information on this.

Both JQuiz and JCloze include the option to add an onscreen keyboard for students to type non-roman characters into answer boxes.

Appendix 4: JMix configuration details
JMix has more buttons than the other programs, because the standard output exercises allow the student to Undo previous actions, and both forms of output include Hint and Restart buttons. As in all the programs, however, all these buttons except for the Check button are optional.

 

The Prompts/Feedback page of the Configuration screen has a checkbox item, Always capitalize first letter. When this option is checked, the first letter of the student's answer will be capitalized (as it should be in a normal sentence) while the exercise is being completed. 
If you are compiling for drag-and-drop output, note that this option can cause slightly annoying behaviour under Internet Explorer; it can cause the text on multiple segments to become selected. You might therefore want to turn the option off if many of your users will be using IE. Also, if you are creating mixed-up-word puzzles (by breaking up one word into separate letters), then you will probably want to turn this off.
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Enter a subtitle to the exercise if desired.





Enter any instructions for the students here.





Insert the message you want displayed to the students when the answer is correct here.





Insert the message you want displayed to the students when the answer is incorrect here.





You can enter another word instead of Check for the “Check Answer” button





This page allows you to change the colours of the different parts of the page e.g. Navigation bar colour, Page background colour etc.





The Preview section on the left will display the changes that are made.








Place a tick next to the options required.





Enter the number of attempts allowed in a hybrid quiz question before it switches to a multiple choice question 
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